Ooidget Component Format 0.1Editor's Draft
References
Normative references
- [RFC2119]
- S. Bradner. Key words for use in RFCs to Indicate Requirement Levels. BCP 14, March 1997.
- [RFC8174]
- B. Leiba. Ambiguity of Uppercase vs Lowercase in RFC 2119 Key Words. BCP 14, May 2017.
- [RFC8259]
- T. Bray, Ed. The JavaScript Object Notation (JSON) Data Interchange Format. STD 90, December 2017.
- [RFC2397]
- L. Masinter. The "data" URL scheme. August 1998.
- [ECMA-262]
- ECMAScript Language Specification, 14th edition (ECMAScript 2023) or later. Ecma International.
- [CSS2]
- Cascading Style Sheets Level 2 Revision 2 (CSS 2.2). W3C.
- [CSS-VALUES]
- CSS Values and Units Module Level 4. W3C.
- [CSS-COLOR-4]
- CSS Color Module Level 4. W3C.
- [CSS-IMAGES-3]
- CSS Images Module Level 3. W3C.
- [CSS-FLEXBOX-1]
- CSS Flexible Box Layout Module Level 1. W3C.
- [CSS-FONTS]
- CSS Fonts Module Level 4. W3C.
- [CSS-TEXT]
- CSS Text Module Level 3. W3C.
- [CSS-EASING-1]
- CSS Easing Functions Level 1. W3C.
- [SVG2]
- Scalable Vector Graphics (SVG) 2. W3C.
- [UIEVENTS]
- UI Events. W3C.
- [WAI-ARIA-1.2]
- Accessible Rich Internet Applications (WAI-ARIA) 1.2. W3C.
- [HTML]
- HTML Living Standard. WHATWG.
- [DTCG]
- Design Tokens Format Module. W3C Design Tokens Community Group.
- [JSON-SCHEMA]
- JSON Schema, draft 2020-12.
- [MQUICKJS]
- Micro QuickJS. F. Bellard. A JavaScript engine for embedded systems.
- [SLINT-MCU]
- Porting Slint to microcontrollers. Line-by-line rendering on a 264 KiB device.
Informative references
- [glTF]
- glTF 2.0 Specification. Khronos Group. The model for this specification's property tables, extensions and conformance.
- [LOTTIE]
- Lottie Animation Format. Lottie Animation Community.
- [ADAPTIVE-CARDS]
- Adaptive Cards. Microsoft. A JSON UI format rendered by many hosts, with fallbacks.